今天对Google Voice中文网进行了一次升级

Google Voice中文网自一年多建站起,一直未对其进行升级。后台的WP一直提醒站长去升级PHP,进而提高Wordpress的性能。

这不,正好有空想起折腾下了。为便于后续的更新(自己之前做了什么)不会出错,特此进行记录下,具体升级工作如下:

  1. 升级LNMP至1.6版本;
  2. 升级nginx至最新稳定版1.16.1;
  3. 升级PHP至最新稳定版7.3.8;
  4. 启用OPCACHE,并优化了内存大小;
  5. 安装了memcached,并优化了内存大小;
  6. 安装了WPJAM插件,设置了相关优化选项。

主要对GV中文网的升级就这么多,不过升级之后出现了“此站点正遇到技术问题。”网站无法打开且无法进入wordpress后台,这还得了,升级就出现错了。

赶紧把WORDPRESS的DEBUG打开,来看下是什么原因导致。错误提示是对象缓存导致的,删除相关的对象缓存文件,立马正常了。

这就好办了,直接换memcached对象缓存插件,一起正常,WordPress的“此站点正遇到技术问题。”得到解决,至此对GV中文网的升级完成。

发表评论

电子邮件地址不会被公开。 必填项已用*标注